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Loading issues and errors encountered after tree data migration

Problem

After upgrading to R4J version 4.7 or higher and executing the tree data migration, some projects are infinitely loading and error pop-ups show in some views.

Cause

The problem could occur if

  1. the tree migration was not executed for all projects.

  2. the integrity checker was not executed before upgrading to version 4.7 or higher.

  3. there are problems with the project migration which resulted in “Migration Failed“ status.

Solution

#1 Check for unmigrated projects

It is recommended that all R4J activated projects are migrated to the new tree data structure. If left unmigrated, it may cause issues with some operations.

  1. Go to Manage Apps Administration > (R4J section) Tree Data Migration.

  2. Select all projects with status “Not Migrated“ and click on the Migrate button. When the migration finishes, the statuses of the selected projects should be “Migrated“.

 

#2 Perform an integrity check in R4J 4.7 or higher

There may be problems with your data even before migration which can cause migration failure or problems with loading the tree.

  1. Execute integrity checks. See Checking the Database Integrity for more details.

  2. Go to Manage Apps Administration > (R4J section) Tree Data Migration.

  3. Select all projects with status “Migration Failed“ and click on the Migrate button. When the migration finishes, the statuses of the selected projects should be “Migrated“.

 

#3 Redo the tree data migration process

This is the last resort and must only be done if solutions #1 and #2 did not work for you.

  1. Delete all entries in AO_242870_PROJECT_TREE_STRUCT. This database table is where the new tree structure is migrated to when tree data migration is executed.

  2. Reset the migration flags in AO_242870_PERMISSION_PROJECT. Set the STATUS_NUM column values to 1.
    STATUS_NUM possible values:

    1 -> Not Migrated

    2 -> Migrated

    3 -> Migration Failed

  3. Install 4.6.x or previously installed lower version.

  4. Follow the Steps 1 through 4 in Migrating Tree Data for versions prior to easeRequirements 4.7.

If the issue(s) persist, retrieve the support zip and the migration logs in <JIRA_HOME>/log/r4j-data-migration-<timestamp>.log, then open a ticket in our support portal for further help with investigation.