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Comment: REQ-20552

Problem

Info

There is a known issue that the coverage view services are not properly updated when updating R4J.
This will result into users not being able to open the coverage view and Jira displaying a message "Oops, an error has occurred".

Solution

Until we find a fix for this problem, the workaround is to uninstall R4J and the Coverage Services dependency followed by a fresh installation of R4J.After installing easeRequirements 4.x or higher manually in the Manage apps administration page, easeRequirements is disabled and cannot be enabled.

Cause

The coverage services is unable to upgrade automatically when a new easeRequirements version is installed.

Solution

  • Go to Administration | Manage Apps

  • Select Manage apps in the left navigation bar

  • Locate 

    R4J - Requirements Management for Jira

    easeRequirements

  • Click on Uninstall and confirm

                 

  • Locate Coverage Services

  • Click on Uninstall and confirm

...

  • Image Modified

  • Re-install the

    R4J add

    easeRequirements add-on through Marketplace or by uploading the obr file.

Info

No data will be lost by uninstalling

R4J

easeRequirements. After the app has been installed again, everything will be as before.