Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: REQ-20552

Problem(s)

...

  1. easeRequirements is successfully installed but disabled and cannot be enabled after installation.

  2. Unable to install

...

  1. easeRequirements to Jira instance. The following error message is encountered:

    Code Block
    An unexpected error has occurred. Please refer to the logs for more information.

Cause

A few common causes:

  1. There is a mismatch between

...

  1. easeRequirements and its dependency, Coverage services.

  2. Your plugin cache may be corrupted.

    • This could occur when there is an interruption with your connection to the server while installation is ongoing.

Solution

There are a few possible solutions. Make sure your connection is stable and perform the suggested solutions in the order presented below.

#1 Re-install

...

easeRequirements

  1. As a Jira administrator, go to Manage apps.

  2. Uninstall

...

  1. easeRequirements.

  2. Uninstall Coverage services.

  3. Install

...

  1. easeRequirements again.

    • This can be done directly through the Marketplace,

    • or the installation file of the desired version can be downloaded here; Then, uploaded to your instance manually.

If this solution does not work, proceed to #2.

#2 Clear plugin cache

  1. Shut down Jira. If multiple nodes are running, shut down all nodes.

  2. Remove the following directories from JIRA_HOME (from all nodes):

    Code Block
    <JIRA_HOME>/plugins/.bundled-plugins
    <JIRA_HOME>/plugins/.osgi-plugins

    If you run with a SHARED_HOME directory, remove these directories:

    Code Block
    <SHARED_HOME>/plugins/.bundled-plugins
    <SHARED_HOME>/plugins/.osgi-plugins

    These will be automatically recreated when your instance is restarted. You can remove them or to be safe, you can move or back them up in another location.

  3. After clearing the plugin cache, restart Jira. If multiple nodes are running, start nodes one by one.

If the issue remains unresolved, please create a ticket in our support portal and provide us with a support zip to further investigate the issue.

...