Jira issue navigator returns incorrect results

Jira issue navigator returns incorrect results

Problem

When right-clicking on a folder to open the Context Menu, upon selecting Show in issue navigator, the Jira issue navigator only shows some of the issues or doesn’t return any result even if there are items under the selected folder.

Project structure with issues under folder “Requirements”:

27b9841e-7f97-4887-b8e0-0553d6d02659.png

 

Empty result screen in the Jira issue Navigator (expected to see issues PS-156, PS-160, PS-164):

Issue Navigator_2.png

Cause

easeRequirements stores the folder information in so called “issue properties” named r4jPath and r4jParent. These are/can be used in the JQL query of the issue navigator as advanced query options.

The app failed to update the issue property due to missing write permission. Most probably the write permission is not granted to add-ons from a Project Permission, Security Level, or Workflow Status Property.

Solution for Project Permissions

To solve this problem, you can add a property for the add-ons by the project role: atlassian-addons-project-access.

You must be a Jira Project Administrator to perform the steps below.

  1. From Project settings > Permissions.

  2. Actions > Edit Permissions.

  3. Update Edit Issues.

  4. Check Project Role > Select atlassian-addons-project-access. Also, check if the user performing the operation has Edit Issues permission.

  5. Update Permissions.

    Project_Permission.png
  6. The solution will be applied to the new folders and issues that will be created.

Solution for Security Levels

To solve this problem, you can add a property for the add-ons by the project role: atlassian-addons-project-access.

You must be a Jira Project Administrator to perform the steps below.

  1. From Project settings > Work items > Security.

  2. Actions > Edit Work Item Security.

  3. Click Add under Actions.

  4. Tick Project Role > Select atlassian-addons-project-access.

  5. Add Access.

    Issue_Security.png
  6. The solution will be applied to the new folders and issues that will be created.

Solution for Workflow Status Property

To solve this problem, you can delete the properties in the status or add a property for the add-ons by the project role: atlassian-addons-project-access.

You must be a Jira Project Administrator to perform the steps below.

  1. From Project settings > Workflows.

  2. Select Edit Workflow.

  3. Navigate to the Status which needs to be modified.

  4. Select Properties, use one of these options:

    1. Delete the all properties which controls the permissions (to revoke all restrictions)

    2. Or add an additional property (to extend current restrictions):

      1. Property Key: jira.permission.edit.projectrole.{unique identifier like 1,2,…}

      2. Property Value: 10003 (This can be found in the Jira System Administration > Project Roles > Hovering over the atlassian-addons-project-access role Action View Usage > Check the bottom left side URL)

        Issue Navigator_4.png

         

  5. Update Workflow.

  6. The solution will be applied to the new folders and issues that will be created.

Solution for already affected folders and issues

For the affected folders and issues created before the changes above, please perform any of the following operations in the tree:

  1. Move the affected issues/folders to a different position/parent and move back to the original position. Tip: If the structure contains multiple sub-items recursively, you can move its topmost parent folder/issue as all items under it will also be processed.

  2. Remove the affected issues/folders from the tree and add them again.

If the issue remains unresolved by the solution provided, please create a ticket in our support portal for our developers to check the background task which processes all the items in the queue table.