DATA CENTER AND SERVER | CLOUD

Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 13 Current »

Technical requirements 

The system requirements and recommendations to install the R4J – Requirements Management for Jira plugin are the same as the Jira installation requirements.

Minimum supported Jira version is 8.5 for the latest releases (since R4J v4.6.0). Refer to the compatibility list in the Marketplace Version History.

It is also important to note that Jira 7 is only supported till R4J v4.5.0 as separate download.

You need to be a Jira Administrator in order to manage plugins. Ensure that you have the latest version of the Universal Plugin Manager installed and follow the steps below to proceed with installation.

  • Download the installation file.

  • As a Jira Administrator, navigate to the Add-on/Apps Administration > Manage add-ons/apps.

  • Click on the link Upload add-on/app.

  • In upload app dialog, browse for the R4J installation file previously downloaded and Upload.

After successful installation of R4J, you can begin exploring the plugin by activating a project.

If you want to use Microsoft Excel to export and import requirements with Jira & R4J, please follow the instructions in /wiki/spaces/REQ4JCLOUD/pages/700514635.

The plugin provides you a project creation template Requirements Management with a few simple issue types and a basic workflow:

  • Customer Requirement

  • Functional Requirement

  • Non-Functional Requirement

  • Improvement

  • New Feature

  • Test Case

You are free to use these issue types or modify them. They are not mandatory for R4J.

 

  • No labels